Mengetahui versi paket aplikasi yang tersedia pada Debian/Ubuntu

Pada saat saya kemarin membuat tutorial instalasi LEMP (Linux, Nginx, MariaDB, PHP) pada Debian 8 ada satu hal yang saya ingin tahu, yakni versi berapa Nginx yang ada pada repository defaultnya. Bukan kenapa – kenapa, tapi kalau terlalu lama/kuno saya mempertimbangkan menambahkan repository milik DotDeb yang lebih baru versinya. Masalahnya saya tidak ingin menginstall dulu Nginxnya dan baru kemudian tahu ini rilis kapan. Repot nantinya kalau harus menghapusnya kalau tidak cocok.

Baca Selengkapnya

Mengatasi The following packages have been kept back

Ada kasus menarik yang terjadi pada salah satu VPS saya yang berisi VestaCP, jadi versi PHPnya masih 5.4 dan ingin saya update ke 5.5 atau 5.6 tergantung yang ada dalam repositorynya waktu itu. Tapi saat menjalankan proses update Debian (dan ternyata di Ubuntu juga) malah muncul pesan error:

The following packages have been kept back:
  libapache2-mod-php5 php-pear php5 php5-cgi php5-cli php5-common php5-curl php5-gd
  php5-intl php5-mcrypt php5-mysql php5-pspell

Ya bingung saja sih, tapi asalkan server masih normal ya bukan prioritas. Akhirnya saya luangkan waktu hari ini untuk cari tahu mengenai detail masalah ini.

Baca Selengkapnya