Sudah saatnya kita meninggalkan PHP 5

Sedikit pesan layanan masyarakat, khususnya bagi administrator server. Kalau di shared hosting masih umum pakai PHP versi 5 dan untuk memaksimalkan kompatibilitas paling baru pun masih PHP 5.6. Nah saya mengingatkan saja bahwa versi ini sudah tidak ada update lagi kecuali soal keamanan. Intinya sudah saatnya kita pindah pakai PHP 7.0 atau bahkan 7.1.

Secara mendetail bisa dicek dari halaman ini: http://php.net/supported-versions.php

Saya sertakan gambarnya juga, bisa terlihat semua versi PHP 5 ( 5.3, 5.4, 5.5, dan 5.6) sudah tidak didukung lagi. Bahkan PHP 7.0 tahun depan (2018) juga sudah EOL. Karena itu sebisanya sudah pakai versi PHP 7.1 untuk semua instalasi web server.

Setidaknya beberapa CMS populer seperti WordPress, phpBB, XenForo sudah mendukungnya. Jadi tidak perlu ragu ada masalah pada kompatibilitas script phpnya.

Saran saya, lakukan bertahap, untuk setiap setup VPS baru pakai stack yang modern. Misal yang biasa saya pilih: CentOS 7, Nginx 1.11, MariaDB 10.1, dan PHP 7.0/7.1. Sederhananya kita melakukan migrasi bertahap. Server lama yang masih bekerja dengan normal biarkan saja pakai stack kunonya. Jangan perbaiki apa yang tidak rusak.

Tinggalkan komentar