Panduan

Cara mengganti versi PHP pada VPSSIM

Secara default VPSSIM menggunakan PHP 5.6, tapi kalau anda membutuhkan versi yang lebih baru seperti PHP 7.0 maka hanya bisa menggantinya setelah proses instalasi. Tapi jangan sampai anda menambahkan sendiri secara manual karena lingkungannya sudah disetup otomatis oleh scriptnya, bisa jadi masalah nantinya.

Serba serbi

Sudah saatnya kita meninggalkan PHP 5

Sedikit pesan layanan masyarakat, khususnya bagi administrator server. Kalau di shared hosting masih umum pakai PHP versi 5 dan untuk memaksimalkan kompatibilitas paling baru pun masih PHP 5.6. Nah saya mengingatkan saja bahwa versi ini sudah tidak ada update lagi kecuali soal keamanan. Intinya sudah saatnya kita pindah pakai PHP 7.0 atau bahkan 7.1.

Web Server

Konfigurasi Nginx untuk CodeIgniter

Sudah lama sekali saya tidak mendengar soal CodeIgniter, tapi masalah error 404 Not Found yang dilaporkan mas Ryuuu membuat saya agak nostalgia. Haha. 😀 Saat membaca pertanyaannya saya cuma terpikir, ini pasti ada urusannya dengan rewrite rule Nginx karena urlnya tidak ditemukan.

Linux

Cara install Composer di Linux

Karena sesuatu hal maka saya terpaksa menonaktifkan forum Servernesia sementara dan mengganti enginenya dari XenForo ke Flarum. Dan sampai saat ini proses instalasi Flarum ini tidak bisa klik – klik seperti CMS umumnya, perlu satu komponen vital bernama Composer yang saya pahami ini package management untuk PHP.

Linux

Cara mengganti versi PHP

Ini sebenarnya masih berhubungan dengan tutorial kemarin soal install PHP-FPM versi terbaru, kan ada 3 versi (5.6, 7.0, dan 7.1). Apabila bingung mau pakai yang mana ya install saja semua, tapi yang diaktifkan cuma salah satu versi saja. Jadi bisa multiple PHP dan dipasangkan bersampingan.